CubieBoard博客-HomeCubieTech公司网站

cubie.cc CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
楼主: @allen

cubieboard运行mainline kernel 4.1 系统教程

[复制链接]

1

主题

0

好友

506

积分

高级会员

Rank: 4

贡献
78
金钱
260
威望
78
买家信用
卖家信用
积分
506
发表于 2015-7-30 12:27:42 |显示全部楼层
已经买了串口线了,等到货。另外问一下,刷入mainline u-boot后,开机启动时蓝绿两个灯会亮么?我刷入sunxi-uboot后,不管内核加载是否成功,至少蓝灯会常亮,但是使用mainline的uboot什么灯都不亮,是不支持还是说加载uboot失败了。如果是不支持,如何修改mainline uboot配置支持led灯?
回复

使用道具 举报

74

主题

5

好友

2万

积分

超级版主

Rank: 8Rank: 8

贡献
3718
金钱
8547
威望
3726
买家信用
卖家信用
积分
20400
发表于 2015-7-30 14:57:17 |显示全部楼层
jump 发表于 2015-7-30 12:27
已经买了串口线了,等到货。另外问一下,刷入mainline u-boot后,开机启动时蓝绿两个灯会亮么?我刷入sunxi ...

参考:http://linux-sunxi.org/Mainline_U-Boot
教程里面也是用Mainline_U-Boot
回复

使用道具 举报

1

主题

0

好友

506

积分

高级会员

Rank: 4

贡献
78
金钱
260
威望
78
买家信用
卖家信用
积分
506
发表于 2015-7-30 18:22:06 |显示全部楼层
@allen 发表于 2015-7-30 14:57
参考:http://linux-sunxi.org/Mainline_U-Boot
教程里面也是用Mainline_U-Boot

linux-sunxi上面的各种教程都试过了,先后刷过mainline u-boot master分支及几个较旧分支,u-boot官方sunxi的mainline分支,sunxi的u-boot,只有u-boot-sunxi成功启动了,其他都不行。我还是等ttl线到了再分享心得
回复

使用道具 举报

74

主题

5

好友

2万

积分

超级版主

Rank: 8Rank: 8

贡献
3718
金钱
8547
威望
3726
买家信用
卖家信用
积分
20400
发表于 2015-7-31 14:43:56 |显示全部楼层
jump 发表于 2015-7-30 18:22
linux-sunxi上面的各种教程都试过了,先后刷过mainline u-boot master分支及几个较旧分支,u-boot官方sun ...

不关双卡版的问题,CB2 双卡版除了NAND的东西 ,其他资料都是一样的。
回复

使用道具 举报

1

主题

0

好友

506

积分

高级会员

Rank: 4

贡献
78
金钱
260
威望
78
买家信用
卖家信用
积分
506
发表于 2015-8-1 19:26:39 |显示全部楼层
@allen 发表于 2015-7-31 14:43
不关双卡版的问题,CB2 双卡版除了NAND的东西 ,其他资料都是一样的。

ttl线到了,按照教程启动失败,卡在starting kernel...那里了。试过稍微旧的201504版本,还是这样,我在试试。。。。
回复

使用道具 举报

1

主题

0

好友

506

积分

高级会员

Rank: 4

贡献
78
金钱
260
威望
78
买家信用
卖家信用
积分
506
发表于 2015-8-2 14:42:23 |显示全部楼层
本帖最后由 jump 于 2015-8-2 14:47 编辑
@allen 发表于 2015-7-31 14:43
不关双卡版的问题,CB2 双卡版除了NAND的东西 ,其他资料都是一样的。

成功刷入了,确定是kernel的问题,使用上述的config编译出来会卡在starting kernel。。。,网上找了一个config文件,编译出来加载成功了,diff了一下,两个config文件相差很大,到底哪部分导致内核启动失败我也没搞清楚

回复

使用道具 举报

74

主题

5

好友

2万

积分

超级版主

Rank: 8Rank: 8

贡献
3718
金钱
8547
威望
3726
买家信用
卖家信用
积分
20400
发表于 2015-8-3 09:53:32 |显示全部楼层
jump 发表于 2015-8-2 14:42
成功刷入了,确定是kernel的问题,使用上述的config编译出来会卡在starting kernel。。。,网上找了一个co ...

我刚才下载最新的内核是可以启动内核的
这是我根据教程配好的.config ,你可以试试
sunxi_defconfig.zip (16.05 KB, 下载次数: 9)

回复

使用道具 举报

1

主题

0

好友

506

积分

高级会员

Rank: 4

贡献
78
金钱
260
威望
78
买家信用
卖家信用
积分
506
发表于 2015-8-3 17:52:59 |显示全部楼层
@allen 发表于 2015-8-3 09:53
我刚才下载最新的内核是可以启动内核的
这是我根据教程配好的.config ,你可以试试

感谢版主回复,确定问题所在了。我的rootfs使用的是debian8,debian init使用了systemd,需要kernel添加cgroup支持,即CONFIG_CGROUPS=y。之前卡在starting kernel这次也发现问题所在,在勾选Kernel low-level debugging functions (read help!),下面的配置没有选定为sunXi UART0,导致误以为卡在了starting kernel,修改后发现卡在了fail to mount tmpfs on /sys/fs/cgroup/,搜索后发现需要添加cgroup支持。添加后系统能很好地启动了。

网上搜到的一份配置我也分享出来,默认集成了无线网卡8188eu等的驱动,只需自己下载fireware就可以使用无线驱动了。 4-2-rc4-a.config.zip (26.12 KB, 下载次数: 11)
回复

使用道具 举报

8

主题

0

好友

1705

积分

金牌会员

Rank: 6Rank: 6

贡献
316
金钱
681
威望
316
买家信用
卖家信用
积分
1705
发表于 2015-9-9 22:55:16 |显示全部楼层
a10启动不能,eth0驱动不行
回复

使用道具 举报

8

主题

0

好友

1705

积分

金牌会员

Rank: 6Rank: 6

贡献
316
金钱
681
威望
316
买家信用
卖家信用
积分
1705
发表于 2015-9-10 12:16:09 |显示全部楼层
本帖最后由 Earthman 于 2015-9-10 12:18 编辑

我下载了4.2kernel,弄了很长时间才搞定
下面是cubieboard-a10的配置
linux-sin4i_config.tar.gz (110 KB, 下载次数: 3)








回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|邮件群发|cubie.cc---深刻的嵌入式技术和应用讨论中文社区 ( 粤ICP备13051116号-1  

GMT+8, 2019-12-11 20:17 , Processed in 0.022708 second(s), 14 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部