CubieBoard博客-HomeCubieTech公司网站

cubie.cc CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
查看: 8296|回复: 9

[已解決]cubian-nandinstall 安裝完成後 , 無法用nand boot

[复制链接]

29

主题

1

好友

7127

积分

论坛元老

Rank: 8Rank: 8

贡献
1338
金钱
2911
威望
1338
买家信用
卖家信用
积分
7127
发表于 2014-10-20 20:13:36 |显示全部楼层
本帖最后由 PeterW 于 2014-10-21 14:16 编辑

請問我用cubian在sdcard上將環境及工具皆安裝好了 ,

sudo cubian-nandinstall 安裝完成後卻無法用 nand 開機 ,

用 ttl 連線看是說找不到 boot.img , 我再用原本之 cubian sdcard

這一片之前是成功制作12台 cb2 cubian 的 , 但一樣也不行了 , 難道是

這一批 cb2 版子與之前的不相同嗎 ?

另外 nand 應該有 nanda , nandb 或是 nandc ? 我有點搞不清楚了 ,

有人可以幫我一下嗎 ? 謝謝 !!

回复

使用道具 举报

0

主题

0

好友

382

积分

中级会员

Rank: 3Rank: 3

贡献
77
金钱
149
威望
77
买家信用
卖家信用
积分
382
发表于 2014-10-20 21:42:35 |显示全部楼层
我今天安装了新版的Cubian X,使用cubian-nandinstall后,移除sdcard后也是无法启动,后来我发现,需要将nandb挂载,并编辑里面的uEvn.txt,将root=/dev/XXX rootwait中的XXX替换为nandb

我的是A10的,你可以参考下
回复

使用道具 举报

29

主题

1

好友

7127

积分

论坛元老

Rank: 8Rank: 8

贡献
1338
金钱
2911
威望
1338
买家信用
卖家信用
积分
7127
发表于 2014-10-20 22:01:48 |显示全部楼层
本帖最后由 PeterW 于 2014-10-20 22:09 编辑
sundev 发表于 2014-10-20 21:42
我今天安装了新版的Cubian X,使用cubian-nandinstall后,移除sdcard后也是无法启动,后来我发现,需要将na ...

您是說將 sudo mount /dev/nandb /mnt/nandb 後

再將 edit /mnt/nandb/boot/uEnv.txt 將 root=/dev/nandc 改為 root=/dev/nandb ?

我改了 , 但是還是開不起來 , 以下為 boot message from TTL

HELLO! BOOT0 is starting!
boot0 version : 3.0.0
dram size =1024
sum=0x01be1e3a
src_sum=0x01be1e3a
Ready to disable icache.
Jump to secend Boot.
[      0.131]

U-Boot 2011.09-rc1-00003-ge89ab14-dirty (Jan 03 2014 - 12:57:33) Allwinner Technology

[      0.141]version: 1.1.0
[      0.144]pmbus:   ready
[      0.249]PMU: AXP209
[      0.252]PMU: AXP20x found
[      0.255]PMU: bat ratio = 100
[      0.258]after set, dcdc2 =1400mv
[      0.262]PMU: dcdc2 1400
[      0.264]PMU: pll1 912 Mhz
boot_clock = 912
dcdc2_vol = 1400
[      0.272]after set, dcdc2 =1400mv
dcdc3_vol = 1250
ldo2_vol = 3000
ldo3_vol = 2800
ldo4_vol = 2800
power_start = 0
storage_type = -1
usb_recovery = 1
find power_sply to end
fel key old mode
run key detect
no key found
no key input
dram_para_set start
dram_para_set end
[      0.308]DRAM:  1 GiB
relocation Offset is: 35b23000
donn't initialize ther user_gpio (main_key:boot_init_gpio)
DRV_DISP_Init: opened
[      0.522]boot_disp.output_type=4
[      0.526]boot_disp.output_mode=4
[      0.529]boot_disp.auto_hpd=1
workmode = 0
[      1.833]NAND: NAND_UbootInit
NB1 : enter NAND_LogicInit
nand : get id_number_ctl from script, 3
not burn nand partition table!
NB1 : nand_info_init fail
[      4.404]nand init fail
set to recovery
try sprite_led_gpio config
sprite_led_gpio start
sunxi sprite begin
screen_width = 800
screen_height = 480
bar x1: 200 y1: 200
bar x2: 600 y2: 280
read mbr failed
sprite update error: no data part found
read mbr failed
sprite update error: read image start error
sprite update error: current card sprite failed
now hold the machine
fail to find part named env
Using default environment

In:    serial
Out:   serial
Err:   serial
--------fastboot partitions--------
mbr not exist
base bootcmd=run setargs_nand boot_normal
bootcmd set setargs_nand
key 0
recovery key high 6, low 4
cant find fstbt value
no misc partition is found
to be run cmd=run setargs_nand boot_normal
the part isn't exist
WORK_MODE_BOOT
WORK_MODE_BOOT
[      4.497]Hit any key to stop autoboot:  0
cant find part named boot
sunxi_flash - sunxi_flash sub-system

Usage:
sunxi_flash read command parmeters :
parmeters 0 : addr to load(hex only)
parmeters 1 : the name of the part to be load
[parmeters 2] : the number of bytes to be load(hex only)
if [parmeters 2] not exist, the number of bytes to be load is the size of the part indecated on partemeter 1
boota: bad boot image magic, maybe not a boot.img?
回复

使用道具 举报

0

主题

0

好友

382

积分

中级会员

Rank: 3Rank: 3

贡献
77
金钱
149
威望
77
买家信用
卖家信用
积分
382
发表于 2014-10-20 22:37:29 |显示全部楼层
我的是A10的板子,nandinstall后,就只有nanda,nandb两个。
回复

使用道具 举报

29

主题

1

好友

7127

积分

论坛元老

Rank: 8Rank: 8

贡献
1338
金钱
2911
威望
1338
买家信用
卖家信用
积分
7127
发表于 2014-10-20 22:42:15 |显示全部楼层
sundev 发表于 2014-10-20 22:37
我的是A10的板子,nandinstall后,就只有nanda,nandb两个。

太晚了 , 明天再試了 , 多謝您了 !!
回复

使用道具 举报

29

主题

1

好友

7127

积分

论坛元老

Rank: 8Rank: 8

贡献
1338
金钱
2911
威望
1338
买家信用
卖家信用
积分
7127
发表于 2014-10-21 08:05:54 |显示全部楼层
昨天又試了一下 , 先用phoenixsuit安裝了一次lubuntu後 , 再一次cubian-nandinstall

好像可以開機了 , 但 boot 後發生錯誤 10 秒後重新再次開機 , 今天再檢查一下

sdcard card 卡上之程式是否正常 , 後續再回報 , 謝謝大家 !!


VFS: Cannot open root device "nandc" or unknown-block(93,3): error -6
[   16.941187] VFS: Cannot open root device "nandc" or unknown-block(93,3): error -6
Please append a correct "root=" boot option; here are the available partitions:
[   16.963357] Please append a correct "root=" boot option; here are the available partitions:
5d00         3891200 nand [   16.981941] 5d00         3891200 nand  (driver?)
(driver?)
  5d01            1024 nanda 00000000-0000-0000-0000-000000000000[   17.001433]   5d01            1024 nanda 00000000-0000-0000-0000-000000000000

  5d02         3890112 nandb 00000000-0000-0000-0000-000000000000[   17.034883]   5d02         3890112 nandb 00000000-0000-0000-0000-000000000000

<0>Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(93,3)
[   17.058060] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(93,3)
[<c0015340>] (unwind_backtrace+0x0/0x134) from [<c0779aa0>] (panic+0xa4/0x1d8)
[   17.082275] [<c0015340>] (unwind_backtrace+0x0/0x134) from [<c0779aa0>] (panic+0xa4/0x1d8)
[<c0779aa0>] (panic+0xa4/0x1d8) from [<c0a7cdc0>] (mount_block_root+0x194/0x224)
[   17.106694] [<c0779aa0>] (panic+0xa4/0x1d8) from [<c0a7cdc0>] (mount_block_root+0x194/0x224)
[<c0a7cdc0>] (mount_block_root+0x194/0x224) from [<c0a7d048>] (mount_root+0x10c/0x114)
[   17.131917] [<c0a7cdc0>] (mount_block_root+0x194/0x224) from [<c0a7d048>] (mount_root+0x10c/0x114)
[<c0a7d048>] (mount_root+0x10c/0x114) from [<c0a7d1e4>] (prepare_namespace+0x194/0x1d8)
[   17.157797] [<c0a7d048>] (mount_root+0x10c/0x114) from [<c0a7d1e4>] (prepare_namespace+0x194/0x1d8)
[<c0a7d1e4>] (prepare_namespace+0x194/0x1d8) from [<c0a7ca90>] (kernel_init+0x23c/0x244)
[   17.183976] [<c0a7d1e4>] (prepare_namespace+0x194/0x1d8) from [<c0a7ca90>] (kernel_init+0x23c/0x244)
[<c0a7ca90>] (kernel_init+0x23c/0x244) from [<c000f740>] (kernel_thread_exit+0x0/0x8)
[   17.210152] [<c0a7ca90>] (kernel_init+0x23c/0x244) from [<c000f740>] (kernel_thread_exit+0x0/0x8)
<2>CPU1: stopping
[   17.230328] CPU1: stopping
[<c0015340>] (unwind_backtrace+0x0/0x134) from [<c0013ea0>] (handle_IPI+0x1b8/0x1cc)
[   17.250050] [<c0015340>] (unwind_backtrace+0x0/0x134) from [<c0013ea0>] (handle_IPI+0x1b8/0x1cc)
[<c0013ea0>] (handle_IPI+0x1b8/0x1cc) from [<c0008528>] (gic_handle_irq+0x54/0x58)
[   17.276111] [<c0013ea0>] (handle_IPI+0x1b8/0x1cc) from [<c0008528>] (gic_handle_irq+0x54/0x58)
[<c0008528>] (gic_handle_irq+0x54/0x58) from [<c000e800>] (__irq_svc+0x40/0x70)
[   17.301685] [<c0008528>] (gic_handle_irq+0x54/0x58) from [<c000e800>] (__irq_svc+0x40/0x70)
Exception stack(0xef065f88 to 0xef065fd0)
[   17.323726] Exception stack(0xef065f88 to 0xef065fd0)
5f80:                   ffffffed 00000001 00000000 00000000 ef064000 c0b394c8
[   17.345517] 5f80:                   ffffffed 00000001 00000000 00000000 ef064000 c0b394c8
5fa0: c078ba30 ef064000 ef064000 c0ad0b10 00000000 00000000 ffff915b ef065fd0
[   17.370976] 5fa0: c078ba30 ef064000 ef064000 c0ad0b10 00000000 00000000 ffff915b ef065fd0
5fc0: c000f800 c000f804 60000013 ffffffff
[   17.393371] 5fc0: c000f800 c000f804 60000013 ffffffff
[<c000e800>] (__irq_svc+0x40/0x70) from [<c000f804>] (default_idle+0x2c/0x30)
[   17.415888] [<c000e800>] (__irq_svc+0x40/0x70) from [<c000f804>] (default_idle+0x2c/0x30)
[<c000f804>] (default_idle+0x2c/0x30) from [<c000faf8>] (cpu_idle+0xe0/0x114)
[   17.442046] [<c000f804>] (default_idle+0x2c/0x30) from [<c000faf8>] (cpu_idle+0xe0/0x114)
[<c000faf8>] (cpu_idle+0xe0/0x114) from [<40775bd4>] (0x40775bd4)
[   17.467124] [<c000faf8>] (cpu_idle+0xe0/0x114) from [<40775bd4>] (0x40775bd4)
<6>[hotplug]: cpu(0) try to kill cpu(1)
[   17.488770] [hotplug]: cpu(0) try to kill cpu(1)
<3>[hotplug]: try to kill cpu:1 failed!
[   19.882550] [hotplug]: try to kill cpu:1 failed!
<0>Rebooting in 10 seconds..[   19.900407] Rebooting in 10 seconds..
回复

使用道具 举报

29

主题

1

好友

7127

积分

论坛元老

Rank: 8Rank: 8

贡献
1338
金钱
2911
威望
1338
买家信用
卖家信用
积分
7127
发表于 2014-10-21 14:15:53 |显示全部楼层
本帖最后由 PeterW 于 2014-10-21 14:25 编辑

問題已解決了 , 原因是新的CB2出廠時是安裝Android , 其中有boot0 , boot1的問題內容線下描述

只要用 PhoenixSuit 先安裝 lubuntu 版本 , 自然會消除 boot0 , boot1 , 再用 cubian-nandinstall

安裝一次即可正確產生 boot 區 , 但是要注意還是要用2樓 sundev 兄說的方法改 root=/dev/XXX rootwait中的nandc替換為nandb才可正常開機 !!


http://cubian.org/2014/06/30/troubleshooting-nandinstall-on-a20/

boot0 and boot1
One known reason of this problem is the boot0 and boot1 code on the device, boot0 and boot1 code is located at a special area, only livesuit can access them AFAIK. They might NOT made for linux. For example, Cubieboard will install an android system on the NAND at factory.

To solve the problem is pretty easy. You just need to use livesuit burn a lubuntu system to nand first, then use cubian-nandinstall afterward.
回复

使用道具 举报

9

主题

1

好友

8946

积分

论坛元老

Rank: 8Rank: 8

贡献
1644
金钱
3908
威望
1644
买家信用
卖家信用
积分
8946
发表于 2014-10-30 10:48:31 |显示全部楼层
Mark 一下。 说不定那天要用这个功能了。
回复

使用道具 举报

1

主题

0

好友

407

积分

中级会员

Rank: 3Rank: 3

贡献
43
金钱
69
威望
143
买家信用
卖家信用
积分
407
发表于 2015-5-28 21:07:25 |显示全部楼层
回复

使用道具 举报

1

主题

0

好友

439

积分

中级会员

Rank: 3Rank: 3

贡献
91
金钱
157
威望
91
买家信用
卖家信用
积分
439
发表于 2016-4-30 03:08:20 |显示全部楼层
我的cubietruck,cubian-nandinstall之后无法启动。先用PhoenixSuit刷了lubuntu,再用烧录了cubian x的tf卡运行cubian-nandinstall,之后在修改nandb甚至nand2都同样无法启动。实在没办法,最后安装了其他系统的nand版。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|邮件群发|cubie.cc---深刻的嵌入式技术和应用讨论中文社区 ( 粤ICP备13051116号-1  

GMT+8, 2019-12-9 20:21 , Processed in 0.032567 second(s), 12 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部