CubieBoard博客-HomeCubieTech公司网站

cubie.cc CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
查看: 4183|回复: 1

Debian下多个wifi环境的配置

[复制链接]

3

主题

0

好友

3215

积分

论坛元老

Rank: 8Rank: 8

贡献
595
金钱
1395
威望
595
买家信用
卖家信用
积分
3215
发表于 2014-5-23 09:18:51 |显示全部楼层
本帖最后由 airpumpkin 于 2014-5-23 09:23 编辑

参考http://www.geeked.info/raspberry ... wifi-access-points/
用的是CTDebian(http://www.igorpecovnik.com/2013 ... eezy-sd-card-image/
没装桌面系统的孩子伤不起啊,拿着CT在家里和办公室来回搬,为了图省事儿,都用的无线连接,要是搬之前忘记改网络配置,那就又得重新连串口设置。需要用到wpasupplicant,CTDebian自带,没有的apt-get install wpasupplicant安装一下。
配置一下/etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet dhcp
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant.conf -B

创建或配置/etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
#ap_scan=2

network={
    id_str="Office"
    ssid="1"
    key_mgmt=WPA-PSK
    psk="12345678"
}

network={
    id_str="Home"
    ssid="2"
    key_mgmt=WPA-PSK
    psk="12345678"                                                                                                                                                              
}
配置好之后,重启就行了。来回搬也不用重新设置网络了,wpasupplicant自动帮你搞定。



回复

使用道具 举报

3

主题

1

好友

377

积分

中级会员

Rank: 3Rank: 3

贡献
79
金钱
129
威望
79
买家信用
卖家信用
积分
377
发表于 2017-4-30 18:24:25 |显示全部楼层



你好,请问cubian网络配置好后,为什么重启后还是没用,要怎么解决
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|邮件群发|cubie.cc---深刻的嵌入式技术和应用讨论中文社区 ( 粤ICP备13051116号-1  

GMT+8, 2020-5-29 06:00 , Processed in 0.028266 second(s), 14 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部