CubieBoard博客-HomeCubieTech公司网站

cubie.cc CubieBoard中文论坛

 找回密码
 立即注册
搜索
热搜: unable
查看: 359|回复: 0

A20的SPI用户程序问题。

[复制链接]

1

主题

0

好友

270

积分

中级会员

Rank: 3Rank: 3

贡献
56
金钱
99
威望
56
买家信用
卖家信用
积分
270
发表于 2018-1-24 09:59:42 |显示全部楼层
本帖最后由 书9500 于 2018-1-24 10:03 编辑

大家好,我在我的A20的板子上移植linux内核源码中的/document/spi/spidev_test.c老是出错误。请看图片。

图片可能有问题,打不开,我直接描述。函数执行到SPI_IOC_MESSAGE的时候会有警告Invaild argument

因为linux-sunxi源码里面没有SPI的驱动,我从网上下载了底层驱动重新编译了内核才发现了/dev/spidev0.0,spi-sun7i.c源码见附件。

实际上只有SPI_IOC_MESSAGE这个cmd不好使,其他的均能正常使用,我也不知道为什么。
老铁们帮帮我啊。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|邮件群发|cubie.cc---深刻的嵌入式技术和应用讨论中文社区 ( 粤ICP备13051116号-1  

GMT+8, 2018-2-20 10:03 , Processed in 0.019242 second(s), 7 queries , Apc On.

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc. | Style by Coxxs

回顶部